[Wine]Problem with accouting SW and Samba/NFS

Bill Medland billmedland at mercuryspeed.com
Mon Apr 11 11:32:09 CDT 2005

On April 11, 2005 05:15 am, fuerst at gmx.li wrote:
> Hi List
> I got following problem:
> I have an old accounting software. It runs at the moment on a
> NT4.0 System which access the program itself on a samba share.
> I tried to get this application running under Linux with wine.
> When I copy the whole folder from the file server to the local
> filesystem (ext2), it works well with wine (tested with
> 20050111 and 20050310). But when I mount the share into my
> drive_c to the correct path (drive_c/KWIN in my case) and
> start the accounting software, the problems are starting. It
> starts up but after providing the password it fails to open
> the database where the data is stored. The application uses a
> Paradox-Engine from Borland btw.
> How is it possible that it works when all the files are on a
> local fs but not when they are on a share? I tested NFS and
> Samba, both fail, changing the behaviour of wine also did not
> help (e.g. switching it to nt40). The filesystem on the
> fileserver is ext3 but I think this definitely should not
> matter.
> Any idea? My boss reported that it once worked with this set
> up but with an older version of wine, I unfortunately don't
> know which version it was.

Don't know, but one possibility is region locking.  Unless 
something has changed while I wasn't looking, the SMB filesystem 
client doesn't handle locking and so the requests won't work.  
Your boss might be talking about a version of Wine from before 
it supported the locking sufficiently well and so it only worked 
by accident.

> thank you very much
> Fuerst

Bill Medland
mailto:billmedland at mercuryspeed.com

More information about the wine-users mailing list