[Wine] DirectSoft 5 Serial communications Issue's

Martin Gregorie martin at gregorie.org
Mon May 21 16:08:42 CDT 2012

On Mon, 2012-05-21 at 15:19 -0500, samuraimarc wrote:
> Hello all, 
> I'm trying to run Automation Direct's DirectSoft 5 PLC software under WINE.  
> Here's what I'm running:
> Lenovo ThinkPad T61 Laptop
> Linux Distro: Debian Squeeze 6.05
> Wine v1.01
> Direct Logic 05 #D0-05DR
> Serial  Communication
That's very old version of Wine. Have you tried using a more recent

> I am aware of the compatibility list for DirectSoft 5 and Automation Direct software.   I am capable of running the software in virtual box but that just brings me back to the frustration of windows. 
> I can successfully run the software in wine if I adjust the DS500.ini COM*ENABLE=  to 0s.  I have tried linking the ttyS0 to com2 (symbolically) with the COM2ENABLE=1 in the .ini and the program hangs. I've also tried Wine v1.4 and have the same issues. 
> Link code: 
> Code:
> ln -s /dev/ttyS0 /~/.wine/dosdevices/com2
1) what happens if you change the access permissions but don't create
   the symlink?

2) what does the command "setserial /dev/ttyS0" show you? 
   On my system it shows:  
     /dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
   so you should see something similar. 

I'm able to access all 5 serial ports on my system (Fedora 16, Wine
1.5.2) with the aid of UDEV local rule that sets /dev/tty[A-Z]*
permissions to 0666 without using any symlinks. In any case this may
work better: 

	ln -s /dev/ttyS0 ~/.wine/dosdevices/COM1:


More information about the wine-users mailing list